プロジェクト

全般

プロフィール

VLAN

VLANの設定

Switch# configure terminal
Switch(config)# vlan 10
Switch(config-vlan)# name V10    
Switch(config-vlan)# exit

VLANの種類

項目 説明
ポートVLAN access
タグVLAN trunk

ポートVLANの設定

Switch(config)# interface range gigabitethernet1/0/1
Switch(config-if-range)# switchport
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# no shutdown
Switch(config-if-range)# exit

ServerやPC側でVLANIDの設定は不要。
ポートに指せば使用することができる。

ポート0~4をVLAN 10
ポート5~9をVLAN 20

上記の様に設定した場合、同一VLAN同士で疎通が可能。
他のVALNと疎通をする為には、VLAN間ルーティングをする必要がある。

タグVLANの設定

Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)# switchport
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# switchport
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# no shutdown
Switch(config-if-range)# exit

ServerやPC側でVLANIDの設定が必要になる。
接続する機器同士のプロトコル合わせる必要がある。

今回の設定の場合は接続側のServer、PC、Switch側でVLANID10を設定する。

VLAN設定の確認

VLAN1はdefaultで設定されています。
VLAN1002から1005は予約されたVLANで設定しなくても出力される。

Switch# show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/3, Gi1/0/4, Gi1/0/5, Gi1/0/6
                                                Gi1/0/7, Gi1/0/8, Gi1/0/9, Gi1/0/10
                                                Gi1/0/11, Gi1/0/12, Gi1/0/13, Gi1/0/14
                                                Gi1/0/15, Gi1/0/16, Gi1/0/17, Gi1/0/18
                                                Gi1/0/19, Gi1/0/20, Gi1/0/21, Gi1/0/22
                                                Gi1/0/23, Gi1/0/24
10   VLAN0010                         active    Gi1/0/1
1002 fddi-default                     act/unsup
1003 trcrf-default                    act/unsup
1004 fddinet-default                  act/unsup
1005 trbrf-default                    act/unsup